Erro ao tentar abrir a janela do relatorio



  • tenho um relatorio que no desenvolvimento visualizo os dados normalmente mas quando abro o Webrun e clico no menu ele abre a janela com este erro abaixo.
    Exceção Gerada:
    java.lang.NullPointerException at wfr.com.WFRMakerReport.createComponents(WFRMakerReport.java:231) at wfr.com.WFRMakerReport.create(WFRMakerReport.java:90) at wfr.com.WFRReport.(WFRReport.java:86) at wfr.com.WFRMakerReport.(WFRMakerReport.java:51) at wfr.com.WFRReportFactory.getInstance(WFRReportFactory.java:162) at wfr.com.WFRReportFactory.getInstance(WFRReportFactory.java:88) at wfr.com.WFRMenuReport.getReport(WFRMenuReport.java:46) at wfr.com.WFRDBSystem.getReport(WFRDBSystem.java:338) at org.apache.jsp.report_jsp._jspService(report_jsp.java:144) at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) at javax.servlet.http.HttpServlet.service(HttpServlet.java:717) at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374) at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) at javax.servlet.http.HttpServlet.service(HttpServlet.java:717) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at wfr.web.ResponseHeaderFilter.doFilter(ResponseHeaderFilter.java:34) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at wfr.web.ContextFilter.doFilter(ContextFilter.java:72) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)


  • Pode informar mais detalhes do seu ambiente?! Você já limpou o cache do webrun (apagando o contexto e gerando um novo)?


  • Consegui resolver apagando os filtros do relatorio, executando novamente e retornando os filtros.

Log in to reply