Não executa fluxos na camada cliente



  • Bom dia, não consigo executar fluxos na camada cliente, aparece 'erro de página' e quando abro o erro aparece o seguinte :
    Mensagem: 'Nome do fluxo' não está definido
    Linha: 394
    Caractere: 1
    Código: 0
    URI: http://127.0.0.1:8087/webrun/wfr.js?hash=5e2b1b1bc4e05a2b8b04138fcce70a4b

    Já exclui a pasta Work reiniciei o Webrun e nada, erro persiste.


  • Possui a pasta Maker.Commons na pasta system? Caso sim, pare o tomcat, renomeie a pasta maker.commons, apague o contexto do webrun, apague a pasta work e efetue o teste novamente.


  • Procedimento realizado mas erro continua.


  • Você criou ou importou alguma nova função no Maker?
    Caso tenha criado/importado, remova a(s) função(ões), reinicie o serviço do Webrun e verifique se o erro continua ocorrendo.


  • Muito provável que exista alguma função incompatível com a camada ou alguma função quebrada ou ainda algum script mal formado. Sugiro que utilize o firebug no firefox para obter mais detalhes sobre o erro.


  • Ok, retornei as versões dos fluxos da camada cliente, provavelmente alguma função ou fluxo salvo de modo incorreto,sistemaq voltou ao normal ,muito obrigado pela ajuda, :D .


  • Boa noite.

    Gostaria de aproveitar este espaço para tirar uma ajuda dos amigos.

    Tenho um subform dentro de outro form e ao chamar um fluxo no evento antes de deletar ou depois de deletar, ele não consegue obter o valor de um componente e também não consegue pegar um campo ou componente.

    Porem em outros eventos ele consegue obter o valor do componente e também pegar um parâmetro do campo ou componente.

    No evento deletar apresenta o erro:

    cannot read property 'getValue' of undefined.

    Grato pela ajuda amigos.
    att.
    Eder.

Log in to reply