Publicação em Servidor



  • Estou tendo problemas ao publicar meu sistema no seguinte quesito:
    Quando rodo minha aplicação local, um determinado valor aparece normalmente: R$560,00
    Quando publico ele no servidor remoto (HE), esse valor aparece R$56,000.00
    Já usei algumas funções para tratar a formatação, converção para fracionário e nada... em uma dessas, mostrou R$56.00.
    Até trocar subsequencia já usei, para trocar virgula por ponto, mas, nada.

    Aguardo uma ajuda, de quem possa.


  • Está usando máscara!?

    Qual?


  • Eu pedo esse dado do banco de dados para mostrar na tela. Já usei a função formatar número com a máscara ###,###,##0.00 e nada.
    Lembrando: localmente sempre funcionou os sistemas, e até mesmo na conta makerplanet que temos, mas em outro servidor, ficou essa doidera.


  • O SO do servidor está configurado com qual região!?


  • É, pelo que você falou, está claro que é configuração de locale do servidor. Tem que corrigir nele. Nessa HE tem como você corrigir e mandar que sua conta fique como português do brasil?

    Se eles não fizerem/não souberem, daí não sei como ajudar.


  • Está em Português Brasil... idioma, moeda, data, tudo configurado para o padrão brasil.


  • Isso na conta do seu usuário? Confirme se a do servidor de aplicação também está. Ou então mude para ele rodar como seu usuário, e veja se fica ok, daí você cria um outro usuário e configura o idioma dele.


  • No meu usuário está tudo em Brazil, Portugues, moeda, data, tudo... muito estranho mesmo.


  • Confirmou as configurações da conta do servidor de aplicações?


  • Problema resolvido.

    Alterei uma caixa que tinha na última aba das configurações regionais, que diz: Apply all settings to the current user account and to the default user profile.
    Apliquei e reiniciei, e funcionou.

    Obrigado a todos que me ajudaram. Fica aí a informação, caso alguém passe pelo mesmo problema.


  • Legal vc ter compartilhado a solução! thanks


  • Estava com o mesmo problema, mas no meu caso era um Windows 2008 Server..
    A opção citada não existia, mas bastou eu ir na Aba Administrative das configurações regionais, Clicar em Copy settings... Marquei as caixas para que ele replicasse as configurações em Português Brasil para as demais opções e funcionou...

    Abraços

Log in to reply