No Simulador Funciona, no Android não



  • O sistema de sincronismo funciona no simulador mas quando colocamos no Android não funciona;

    Estamos usando a mesma maquina servidora e mesma base para testar tanto no simulador quanto no Android.

    No simulador baixa os dados da tabela OUT e envia os dados da tabela IN.

    Já no Android baixa as OUT mas não envia para IN.

    Nas tabelas IN tinha trigger associada, então tiramos as trigger e deixamos so as tabelas sem nenhuma restrição, nada que poderia impedir um insert.

    Refizemos os testes e mesma coisa.
    Com o simulador funciona com o Android não.

    Testamos em vários aparelhos.

    Smartphone Milestone 1
    Tablet Galaxy Sansung
    Tablet Motorola Xoom
    Tablet Chine com Android 2.3
    Emulador do Android

    Em nenhum deles o sincronismo funcionou.


  • Leandro, neste post (http://forum.softwell.com.br/viewtopic.php?f=45&t=60&p=185#p185) você informa que está utilizando o sincronizador sem problemas, o que houve?

    - passou a ocorrer problemas após um certo procedimento?
    - no momento do citado post, você só havia testado no simulador?


  • O Sincronizador funciona no Simulador.

    Como falei no post.

    O problema e que quando exportamos para Android não funciona.

    O sincronizador funciona no Simulador mas não no Android.


  • Certifique-se que o servidor é acessível pelo aparelho, dependendo de como está sua rede os dispositivos não vão conseguir resolver o nome do servidor.

    Verifique se:
    * O aparelho tem um IP na mesma rede do servidor;
    * O nome do servidor está absoluto ou por IP público, não use localhost ou nomes que são resolvidos na rede do Windows apenas;
    * Os aparelhos tem espaço de armazenamento suficiente (na área de dados dos apllicativos)

    Att,

Log in to reply