Servidor Cloud



  • Como faço para publicar minha aplicação num servidor cloud?


  • Qual a dificuldade?


  • Eu instalo a aplicação no servidor, da mesma forma que faço localmente mas qnd tento acessar pela URL não funciona


  • [quote="Linsmar"]Eu instalo a aplicação no servidor, da mesma forma que faço localmente mas qnd tento acessar pela URL não funciona[/quote] O fato de ser Cloud não quer dizer nada em relação ao seu problema.

    1) Qual OS ?
    2) Você instalou usando o instalador do Webrun ou instalando o servidor de aplicações em separado ?
    3) Qual o servidor de aplicações ?
    4) Você está acessando a URL de fora do servidor ou de dentro (localhost) ?
    5) Você sabe o que você está fazendo ?


  • Se vc tiver usando um servidor WINDOWS, instale o sistema completo do maker, com isso fica mais fácil vc rodar seus aplicativos após a publicação no mesmo. Na locaweb funciona bem, eu tenho um cloud lá e ficou show, apenas levo a aplicação para o mesmo. Outra situação é vc empacotar o projeto e depois mandar para esse servidor e instalar o mesmo lá.

    :mrgreen:


  • Olá marlonapcred / Saeger.

    Estou tentando publicar minha aplicação na LocaWeb mas não estou conseguindo fazer o Webrun "localizar" o sistema. O webrun abre normalmente, mas a lista fica em branco.

    Já tentei colocar o JAR e o WFRE em tudo que é pasta, mas não faz diferença.
    Preciso configurar algo no TOMCAT?

    Aguardo urgente.
    Já faz 3 semanas que estou procurando um Cloud, mas tá complicado.

    Desde já agradeço.
    Lúcio Nascimento


  • Prezado Lúcio, bom dia!
    Qual o SO?
    Provavelmente deve estar faltando o WEBRUN_HOME

    [b]No linux:[/b]
    #!/bin/bash
    # description: Tomcat Start Stop Restart
    # processname: tomcat6
    # chkconfig: 234 20 80

    WEBRUN_HOME=caminho_do_tomcat
    export WEBRUN_HOME

    [b]No Windows[/b]
    [105_screenshot_4.png](/assets/uploads/files/105_screenshot_4.png)


  • Olá Glauber.

    Obrigado pela ajuda.

    É no Linux mesmo. Do qual não conheço praticamente nada.
    Estou acessando pelo SSH (PuTTY).

    Fiz como você falou. Executei: WEBRUN_HOME=caminho_do_tomcat export WEBRUN_HOME. Aparentemente deu certo.
    Depois dei o comando SET, e aparece a variável lá. Ok.
    Mas ao sair do PuTTY, voltar e dar o comando SET, a variável WEBRUN_HOME não está mais lá. ??????
    Tem que dar algum comando pra ela ser permanente?


  • usa esse comando:
    [i]source enderecodoseuscript.sh[/i]


  • Olá Glauber.

    Não entendi.

    Eu estou digitando os comando no prompt do PuTTY (SSH).
    Não tenho nenhum arquivo .sh

    Pelo FTP do Cloud, tem uma pasta BIN, e dentro dela tem um arquivo "startup.sh".
    Editei esse arquivo, colocando a linha abaixo
    WEBRUN_HOME=/opt/tomcat/temp/webrun export WEBRUN_HOME
    depois reiniciei o Tomcat.
    Acessei via SSH, dei o comando SET, e a variável WEBRUN_HOME não aparece.

    E agora?

    Lúcio
    (62)8414-5995 (Oi)
    lucio.sistemas@gmail.com


  • Olá,
    Conseguiiiiiiiiiiiiiiiiiii!!!!!!!!!!!!!!!!!!

    Pelo FTP, dentro da pasta /conf tem o arquivo "tomcat-env.sh". Vi que nele eram criadas muitas variáveis. Incluí a minha lá (WEBRUN_HOME), reiniciei o Tomcat, e aí achou meu sistema.

    Muuuuito obrigado pela ajuda.

    Att,
    Lúcio


  • Olá,

    Agora estou com dificuldade para instalar e usar o WINE (para os relatórios), no Linux CentOS 6.6

    Primeiro procurei informações no Manual do Maker3.
    Lá, ao procurar por Wine, aparecem 3 links. Mas nenhum está ajudando. Está mencionado abaixo o problema de cada um.

    1. http://suporte.softwell.com.br/maker/manual_3/pt/webrun_3/instalando_o_webrun_no_fedora_Core9_.htm

    Item: Instalando o Wine
    A instalação do WINE é bem simples, apenas execute como root:
    #yum install wine
    ERRO: No package wine available. Error: Nothing to do
    Não tem que baixar o Package do Wine primeiro? Lá não menciona nada.

    2. http://suporte.softwell.com.br/maker/manual_3/pt/recursos_avancados/geracao_codigo_fonte/geracao_codigo_fonte.htm
    Só faz uma menção ao Wine, na linha "Wine 1.6(ver observação 2);".
    Só que não existe nenhuma "observação 2".

    3. http://wiki.softwell.com.br/WebrunCentOS5
    Item: Instalando o Wine
    Para instalar o Wine, é necessário adicionar o repositório do EPEL, executando como root:
    #rpm -Uvh http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
    Esse link não funciona mais, então não dá pra continuar seguindo as instruções.

    Recebi do suporte da Softwell um doc feito no Word, com o título "Publicando o Webrun em sistemas Linux Ubuntu".
    Mas como estou utilizando o CentOS, o comando não funciona.
    sudo add-apt-repository ppa:ubuntu-wine/ppa;

    Achei até no Fórum alguma coisa, mas o link sugerido também não funciona mais.

    Já fiz buscas na Internet, para poder instalar, mas não consegui finalizar a instalação.
    Estou tentando instalar a versão 1.6.2.
    O link que consegui ir mais adiante foi http://www.unixmantra.com/2014/03/how-to-install-wine-1.6.2v1.html
    O problema é que seguindo as instruções, fui até o comando "make", mas fica num loop eterno. Já deixei processando mais de 30 minutos e não encerra.

    Alguma sugestão?
    Desde já agradeço a ajuda.

    Att.
    Lúcio


  • Em outra ocasião, o mesmo informou que já foi solucionado.


  • Para acessar via URL pelo IP da máquina, verificar se as portas no CLoud estão abertas.

Log in to reply