Erro Connection refused wfr.exceptions.WFRReportException: Connection refused

Dúvidas referente a instalação, configuração e utilização do Servidor de Relatórios.

Moderador: Softwell

danilo
Maker Noob
Maker Noob
Mensagens: 2
Registrado em: 19 Dez 2019, 09:40

Erro Connection refused wfr.exceptions.WFRReportException: Connection refused

Mensagem por danilo » 19 Dez 2019, 15:10

Prezados, boa tarde, estamos enfrentando um problema que ocorre nos dois ambientes (homologação e produção) durante a geração de relatórios no maker.
Atualmente utilizamos o Maker 2.7.0.0 e Webrun 2.7.0.40.
Os usuários estão utilizando normalmente a aplicação, porém por algum motivo o serviço de impressão de relatórios para de responder e a aplicação não consegue gerar os relatórios dos usuários, exibindo a mensagem:

"
Exceção Gerada:
wfr.exceptions.WFRReportException: Connection refused: connect at wfr.sys.HTMLInterface.HTMLReport.createReport(HTMLReport.java:859) at wfr.sys.HTMLInterface.HTMLReport.openReport(HTMLReport.java:596) at wfr.web.actions.ReportOpenExternalAction.execute(ReportOpenExternalAction.java:59) at wfr.web.Action.doAction(Action.java:126) at wfr.web.Controller.process(Controller.java:129) at wfr.web.Controller.doGet(Controller.java:59) at javax.servlet.http.HttpServlet.service(HttpServlet.java:621) at javax.servlet.http.HttpServlet.service(HttpServlet.java:728) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210) at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749) at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:487) at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:412) at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339) at wfr.web.WFRCore.process(WFRCore.java:42) at wfr.web.WFRCore.doGet(WFRCore.java:28) at javax.servlet.http.HttpServlet.service(HttpServlet.java:621) at javax.servlet.http.HttpServlet.service(HttpServlet.java:728) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210) at wfr.web.ContextFilter.doFilter(ContextFilter.java:87) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:502) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99) at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:953) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408) at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1023) at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589) at org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:1852) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source)
"

Configuração dos ambientes:
  • Ambiente de Produção: Dedicado para o Servidor de Relatórios
    • Servidor de Relatórios Maker 2.7 / ReportController_2.7.0.39
    • S.O: Windows 2012 Server R2
    • Memória: 8Gb Ram
    • Cpu: 4 cpu's
  • Ambiente de Homologação:
    • Servidor de Relatórios Maker 2.7 / ReportController_2.7.0.39
    • S.O: Windows 2012 Server R2
    • Memória: 6Gb Ram
    • Cpu: 6 cpu's
Alguém já passou por este problema? O que pode estar ocorrendo? Como posso corrigir?
Responder