Componente Gráfico no formulário com erro



  • Criei um componente gráfico utilizando a tabela FR_ACAO e apresentou o seguinte erro
    [quote]Exceção Gerada:
    java.lang.NullPointerException at wfr.sys.HTMLInterface.HTMLElementFactory.getInstance(HTMLElementFactory.java:199) at wfr.sys.HTMLInterface.HTMLChart.(HTMLChart.java:94) at wfr.sys.HTMLInterface.HTMLElementFactory.getInstance(HTMLElementFactory.java:260) at wfr.sys.HTMLInterface.HTMLForm.createElements(HTMLForm.java:2500) at wfr.sys.HTMLInterface.HTMLForm.absolute(HTMLForm.java:1167) at wfr.web.actions.OpenformAction.execute(OpenformAction.java:53) at wfr.web.Action.doAction(Action.java:126) at wfr.web.Controller.process(Controller.java:141) at wfr.web.Controller.doGet(Controller.java:60) at javax.servlet.http.HttpServlet.service(HttpServlet.java:617) at javax.servlet.http.HttpServlet.service(HttpServlet.java:717) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at wfr.web.ContextFilter.doFilter(ContextFilter.java:87) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:879) at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:600) at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1703) at java.lang.Thread.run(Thread.java:595)[/quote] Esses foram os passos que executei no formulario
    [img]https://dl.dropboxusercontent.com/u/62251547/erro/erro_grafico1.jpg[/img]
    [img]https://dl.dropboxusercontent.com/u/62251547/erro/erro_grafico2.jpg[/img]


  • https://www.youtube.com/watch?v=2IBT38UfIiE


  • [url]https://www.youtube.com/watch?v=lgNhO6J81eY[/url]


  • Caro, confirma se a série do gráfico foi persistida no componente.

    Após salvar o formulário, feche-o e abra-o novamente para verificar se foi persistida.


  • Erro Corrigido
    obrigado

Log in to reply