Erro ao gerar relatório - Connection refused: connect



  • Olá pessoal,

    tenho um relatório no projeto e esta funcionando em ambiente de homologação normalmente.

    Em um determinado servidor, utilizei o seguinte [url=http://www.softwell.com.br/2012/09/criando-instancias-para-o-tomcat/]tutorial[/url] para criar várias instâncias do Tomcat.

    Acontece que agora os relatórios não abrem, quando clico no botão "Visualizar" aparece a seguinte mensagem de erro:

    Erro ao gerar relatório.
    Connection refused: connect

    Abaixo a exceção gerada:

    wfr.exceptions.WFRReportException: Connection refused: connect at wfr.sys.HTMLInterface.HTMLReport.createReport(HTMLReport.java:857) at wfr.sys.HTMLInterface.HTMLReport.openReport(HTMLReport.java:596) at wfr.web.actions.ReportOpenAction.execute(ReportOpenAction.java:34) at wfr.web.Action.doAction(Action.java:126) at wfr.web.Controller.process(Controller.java:129) at wfr.web.Controller.doPost(Controller.java:69) at javax.servlet.http.HttpServlet.service(HttpServlet.java:643) at javax.servlet.http.HttpServlet.service(HttpServlet.java:723) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at wfr.web.ContextFilter.doFilter(ContextFilter.java:87) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:606) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489) at java.lang.Thread.run(Unknown Source)

    Alguém já passou por isso?

Log in to reply