Erro cabeçalho em RTF



  • Boa tarde,
    estou com um problema com um cabeçalho em RTF, utilizo o componente DBRichText para o mesmo (acho que é esse o nome).

    O que acontece:

    No simulador no ambiente de desenvolvimento Maker 2.7, o cabeçalho é apresentado corretamente.
    No Webrun, também apresenta corretamente,
    porém ao simular em outra máquina com o mesmo banco de dados (mesmo conteúdo RTF), ou em clientes o cabeçalho sai totalmente errado e ilegível.

    Não sei mais o que pode ser...
    Alguém já passou pela mesma situação ou poderia ajudar a resolvê-la ? (Segue imagens em anexo)

    Atenciosamente,
    Rafael Withoeft


  • Qual a versão do ReportController na máquina que ocorre o problema?


  • Pelo que visualizei,

    2.7.0.0


  • [quote="rafaelw"]Pelo que visualizei,

    2.7.0.0[/quote] Confirme com o autotest.

    Temos registro de um problema semelhante com a versão 2.7.0.10


  • Sim, é está versão mesmo, 2.7.0.0


  • Você possui alguma versão mais recente que resolveria o problema?


  • Veja esta versão.

    http://download.softwell.com.br/makergold/reports/ReportController_2_7_0_42.zip

    Como informei, temos registro deste problema na versão 2.7.0.10 que foi corrigido nas versões mais recentes (patches). Verifique se funciona com esta versão e nos reporte qualquer coisa.


  • Desculpe, mas o problema persiste.

    Retirei a antiga pasta, coloquei sua nova versão, recompilei o sistema, testei em 3 navegadores diferentes, limpei os dados de navegação, parei e iniciei novamente o webrun, finalizei todos os processos referentes ao Report e tentei novamente...

    o que mais posso tentar fazer?


  • A atualização foi feita no computador de desenvolvimento ou no seu cliente final?


  • Fiz a instalação em meu computador de desenvolvimento, instalei o módulo e fiz teste com um banco padrão que apresentava o problema, assim sendo não acessei o mesmo pelo webrun, mas se for preciso posso testar em um cliente.


  • [quote="rafaelw"]No simulador no ambiente de desenvolvimento Maker 2.7, o cabeçalho é apresentado corretamente.
    No Webrun, também apresenta corretamente,
    porém ao simular em outra máquina com o mesmo banco de dados (mesmo conteúdo RTF), ou em clientes o cabeçalho sai totalmente errado e ilegível.

    Não sei mais o que pode ser...
    Alguém já passou pela mesma situação ou poderia ajudar a resolvê-la ? (Segue imagens em anexo)[/quote] Entendi. É porque você reportou que o problema ocorria em outros clientes. Então agora acontece também no seu ambiente?


  • Eu simulei um ambiente de cliente em meu computador,

    No Maker (Ferramenta) continua funcionando normalmente, instanciando a aplicação pelo webrun também funciona normalmente,
    o problema aparece quando vou instalar a aplicação mesmo (webrun + sistema), faço todos os procedimentos, instalar webrun, instalar a aplicação(arquivos) dentro do tomcat conforme as especificações necessárias e após substituo a pasta reports do webrun pela mais recente.

    Porém o problema persiste.

    Gostaria que eu fizesse o teste em algum cliente?


  • E o seu projeto vai para o cliente de que forma? Vc gera o war ou usa interpretado?


  • Posso fazer das 2 formas, ultimamente estou gerando um war em minha máquina e descompactando pelo tomcat, pegando seus arquivos e gerando um instalador, para facilitar a implantação.

Log in to reply