CARREGAR MÚLTIPLOS SISTEMAS NO WEBRUN



  • Caros Amigos, Boa Tarde !

    Eu tenho um sistema que trabalha com múltiplos banco de dados.
    O Sistema tem um WFRE principal e vários outros WFREs na pasta DataConnection.
    O Sistema funciona normalmente. Ao rodar o WAR ele mostra o sistema e consigo conectar em cada banco de dados, vendo assim suas informações.
    Nossos clientes usam o sistema sem nenhum problema. Mais tem uma coisa que está me deixando de cabelo em pé:

    Eu preciso usar a função GERAR RELATÓRIO para criar um arquivo PDF. Toda vez que eu rodo essa função, ao invés dele buscar as informações no banco de dados conectado, ele sempre busca as informações no banco de dados do WFRE principal. Tudo no sistema busca do WFRE conectado, menos quando uso a função GERAR RELATÓRIO.

    Meu Ambiente:
    WEBRUN 2.7.0.44
    Reports 2.7.0.10
    Instancia configurada em todos os WFREs
    Já fiz limpeza de Cache

    Alguém poderia me dar uma ajuda?

    Forte abraço!
    Watson


  • Olá Watson, poderia confirmar a versão de sua API.


  • Olá Ronélio,
    O que seria a API? A versão do Webrun é 2.7.0.44.

    Em O que mais eu poderia lhe informar, é só me pedir que te passo na hora.


    Obrigado pela ajuda.

    Abraços!
    Watson


  • A API é o conjunto de funções usadas no desenvolvimento de seus fluxos.

    Para obter a sua versão, use o script select pro_valor from fr_propriedade where pro_nome like '%API%' no executor de scripts.


  • Olá Ronélio,
    A Consulta me retornou duas linhas: As duas contem a versão 1.1.18

    Como devo proceder agora?


  • Só mais uma informação, usou o guia disponível neste link
    http://suporte.softwell.com.br/maker/manual2_7/pt/dicas_e_truques/webrun/carregando_multiplos_sistemas_webrun.htm
    ?
    Darei uma olhada aqui e posto o feedback depois.


  • Olá Ronéio,
    Sim, usei esse link sim.

    Eu tenho um WFRE Principal. E dentro da minha pasta DataConnections eu tenho mais 30 WFREs. Quando acesso o sistema, eu informo o login e a senha e a entidade.
    Entrando no sistema, tudo me é mostrado do banco de dados do WFRE conectado.
    Mais a função GERAR Relatório sempre busca do WFRE principal, não respeitando o WFRE conectado.

    Todos os meus WFRE estão com um nome de instância.

    Minha publicação é em WAR. Eu ja gero o WAR Configurado, de forma que não tenha que fazer nada em produção. O Sistema está funcionando, já em 30 clientes. Mais essa Função GERAR RELATóRIO me deixou na mão.

    Se puder me ajudar, fico muito agradecido.

    Abraços!
    Watson


  • Eu vi que a função GERAR RELATóRIO usa uma variavel connection que não foi passada na assinatura do método. Será que tem algo a ver?

    Abraços!


  • Olá Ronélio,
    Obrigado por estar nos ajudando.
    o Sr. conseguiu ver algo sobre o assunto?

    Grande abraço!
    Watson


  • [quote="inosys"]Olá Ronélio,
    Obrigado por estar nos ajudando.
    o Sr. conseguiu ver algo sobre o assunto?

    Grande abraço!
    Watson[/quote] Olá Watson, estamos verificando ainda. Estou suspeitando de um problema na função.

    A necessidade de uso desta função é para enviar por email, por exemplo?


  • Olá Sr. Ronélio,
    Obrigado pelo retorno.

    Sim, estou precisando de gerar o PDF para poder enviar via e-mail em anexo.
    O Sistema gera o arquivo, eu pegaria o caminho e enviaria um e-mail para o cliente.

    Obrigado pela ajuda!

    Abraços!


  • Olá Sr. Ronélio,
    Desculpe o incomodo, mais o pessoal do suporte me disse que estão testando uma nova versão da função GERAR RELATÓRIO. Só que isso ja tem quase 10 dias ou mais. Sabe me informar em que status se encontra esse teste?
    Nossos clientes já não estão aguentando mais e tememos perder alguns. Parece ser pouca coisa, mais deixar de enviar cobrança em pdf é tenso.

    Poderia me posicionar a respeito?

    Obrigado!

    Watson


  • [quote="inosys"]Olá Sr. Ronélio,
    Desculpe o incomodo, mais o pessoal do suporte me disse que estão testando uma nova versão da função GERAR RELATÓRIO. Só que isso ja tem quase 10 dias ou mais. Sabe me informar em que status se encontra esse teste?
    Nossos clientes já não estão aguentando mais e tememos perder alguns. Parece ser pouca coisa, mais deixar de enviar cobrança em pdf é tenso.

    Poderia me posicionar a respeito?

    Obrigado!

    Watson[/quote] Olá, liberamos um patch de correção hoje. Entre em contato com o suporte para obter o link.

    Este patch é específico para correção deste problema com o gerar relatório (e outros ajustes). Baixe a versão e nos dê um feedback.

    Abraço.


  • Olá Ronélio,

    Fiz os testes e funcionou corretamente agora.
    Sabe me informar quando vai sar como atualização final?

    Obrigado pela ajuda, Deus Abençoe sua Vida !

    Att
    Watson Passos


  • Não temos um prazo definido para liberação oficial desta versão. Como é um patch e é uma versão recente, demandará mais testes antes da distribuição via atualizador automático.

    Quando estiver disponível notificaremos aos clientes.

    O tópico será encerrado qualquer dúvida poderá abrir um novo tópico.

Log in to reply