Erro depois que atualizei o maker e webrun



  • Não consigo mais gravar do formulário para o banco de dados pelo webrun.

    Vou direto no banco de dados e consigo gravar na tabela desejada.


  • Já republiquei.

    Já coloquei vários webruns que tenho e nenhum funcionou.

    O que pode ser ?


  • Esse formulário simples apos o seu preenchimento não esta gravando os dados.
    [148_erro_banco_tres.png](/assets/uploads/files/148_erro_banco_tres.png)


  • Os logs do tomcat. Nao sei mais o que fazer.
    [148_logs.rar](/assets/uploads/files/148_logs.rar)


  • Logs do postres.

    Pode ser burrada minha mas nao estou conseguindo identificar o erro.
    [148_pg_log.rar](/assets/uploads/files/148_pg_log.rar)


  • Cara... cria um novo banco (Estrutura e relacionamentos), exporta os forms, fluxos e relatórios do seu projeto e importa no novo banco.

    Solução radical. Testa isso.


  • pensei nisso.

    mas se isso acontecer de novo vou ter que fazer de novo. :? :?


  • Cara, esse "acontecer de novo" é complicado dizer..
    O problema não acontece sozinho, alguma coisa que motiva.
    Trabalho há anos com Maker e nunca vi isso.. não gosto de julgar sem saber o real motivo, mas nesse tipo de caso, a primeira coisa que vem na minha cabeça é algum erro na manipulação do projeto, por parte do desenvolvedor.
    Enfim.. não vem ao caso agora. O objetivo é resolver.

    Faz isso, resolve o problema e fica ligado se vai acontecer de novo. Caso aconteça, volte aqui e o grupo vai te ajudar a fazer uma análise mais profunda do caso.

    Boa sorte aí, abraço.


  • Tambem trabalho a bastante tempo com o MAKER, tambem nunca ocorreu isso. Achei estranho. mas vamos resolver.


  • O Raphael no GUMAKER encontrou a solução.

    Como disse ERRO meu. Estou inserindo dados na tabela fr_log_event. Vou modificar. Não sabia que isso poderia ocasionar o erro.
    [quote]Guilherme, isso deve ser problema nas tabelas fr de log do banco de dados, está tentando gravar registro duplicado.
    Tentar deletar todos registros da tabela fr_log_event direto no banco de dados.[/quote] [quote]Depois reinicia a sequence da tabela fr_log_event[/quote]


  • Que bom que resolveu então. Show de bola.


  • Fiz o que vc falou e deu o mesmo erro.

    Mas o importante é que foi resolvido.

    :) :D


  • lógico que não era pra funcionar ne? rsrs

Log in to reply