[Resolvido] Lista Filtrando Lista: Informações Desaparecem



  • Tenho um formulário de cadastros onde possuo 4 listas dinâmicas simples UF, Cidade, Bairro e Logradouro

    [img]http://imageshack.us/a/img845/749/80879226.jpg[/img]
    as 4 são filtradas umas pelas outras Cidade pelo Uf, Bairro pela Cidade e asim por diante ate obter o CEP.

    [img]http://imageshack.us/a/img689/407/87852095.jpg[/img]
    Na consulta de cada uma eu usei a função "=:componente_" conforme o Manual Maker>> http://suporte.softwell.com.br/maker/manual/dicas_e_truques/filtrar_a_partir_de_componentes_nao_ligados_ao_banco.htm

    [img]http://imageshack.us/a/img18/8108/62853344.jpg[/img]
    bom a principio funcionou perfeitamente

    [img]http://img837.imageshack.us/img837/26/43091729.jpg[/img]

    mas depois de gravado o registro, as informações desaparecem

    [img]http://img687.imageshack.us/img687/842/91999827.jpg[/img]

    Gravei um vídeo para ajudar >> http://www.youtube.com/watch?v=9JhEKkyviTc

    Já deletei os campos e criei de novo, deletei os componentes e criei de novo e nada. Aguardo uma ajuda e desde já agradeço :D


  • Lucas, efetue o filtro pelo campo e não pelo componente EX :nomeDoCampo

    Filtrando pelo componente, vc terá que atualizá-lo durante a navegação, para que o conteúdo apareça, pelo campo não é necessário isso, a menos que seu componente não esteja ligado a banco, logicamente.


  • Sempre que eu venho aki com uma duvida tenho meu problema solucionado :D . Valew andersonleal espero que minha experiencia ajude outros usuários. :)


  • Flws!

Log in to reply