Erro após publicar WAR



  • O cliente possui um abiente Linux Ubuntu. Para a instalação utilizei o procedimento "Procedimentos para instalação de um ambiente dedicado para o Webrun no Linux " encontrado no manual do Maker 2.6.

    Banco de Dados postgresql 8.2.11
    Ambiente exportado: .war

    O webrun levanta permite selecionar o sistema, autentica o usuário, mostra todo o menu e os formulários,mas quando vou abrir qualquer formulário (default do sistema ou customizado) não mostra os componentes, principalmente os formulários que possuem grades!!!!

    Por Favor me ajudem!!!!

    At
    Eduardo


  • podem encerrar...
    resolvido


  • Boa noite efreitas, você poderia postar como você solucionou? Vou tentar publicar um pequeno sistema em linux.

    Grato,

    Renato


  • Provavelmente o problema ocorreu por utilizar uma versão 2.6 com os browsers atuais (FF 10+ e Chrome).


  • Nao foi problema com o browser.

    a Documentacao da softwell nao e transparente e dificulta muito.

    quem resolveu foi o prorpio cliente, e o mesmo nao deu maiores informacoes

    ele formatou a maquina novamente e subiu o linux ubuntu

    o que foi feito diferente:
    jrockit (uma versao diferente a que e informada no procedimento da softwell, pois a versao informada nao e encontrada em lugar algum e o suporte da softwell nao fala nenhum comnetario)
    escreveu dentro do catalina alguns scritpty (eu sou leigo... nao sei o que foi escrito)
    declarou variaveis e exportou

    so depois disso fez os procedimentos do webrun.

    mesmo assim os relatorios em PDF nao funcionam, ja abrir suporte e nada


    Caros amigos, quem for utilizar aplicativos desenvolvidos em maker em um servidor linux, tem que ser fera em linux... e tatear.... pois se depender de um suporte da softwell para simplesmente colocar o aplicativo para funcionar, ta ferrado!!!! esquecam, a documentacao e horrivel, te leva do nada para lugar algum, e vc ficara como eu, com carao junto ao cliente, veja o tempo que foi publicado isso, tirando o que ja foi postado no canal de suporte!!! nem mesmo ligando diretamente, eles dao uma mior desculpa...
    nada que eles dizem funciona..... acredito que como um empresa seria (como eles dizem) tinha que ter um roteiro basico para funcionamento para uma maquina formatada... tenta encontrar isso!!!!

    Entao meu caro, se vc vai instalar em linux desenvolva em outra ferramenta, onde vc possa encontrar suporte com maior clareza....de menos no maker!!!


  • Entendo.
    [quote="efreitas"]quem resolveu foi o prorpio cliente, e o mesmo nao deu maiores informacoes[/quote] Pelo erro que vc informou, provavelmente foi utilizada uma versão 2.7. Versão 2.6 não aparece a grade nos browsers novos.

    Apesar da JRockit existir no servidor da Softwell, http://download.softwell.com.br/webrun/linux/jrockit-jdk1.5.0_24-R28.1.0-4.0.1-linux-ia32.bin, em todo teste que fiz aqui nunca utilizei.

    Basicamente o que fiz foi:
    a. Instalar uma JDK 1.5;
    b. Instalar o Apache Tomcat 6.0.35;
    c. Colocar o webrun.war na pasta webapps do tomcat;
    d. Criar um webrun.ini e colocar na pasta /usr/lib (O Webrun.ini deve conter o caminho dos arquivos do webrun (pasta systems, config e reports));
    e. Configurar o Wine;

    No Wiki http://wiki.softwell.com.br/WebrunCentOS5, tem as informações necessárias.


  • Ronélio, desde já agradesço o seu envolvimento.... e com certeza os participantes do forum são muito mais atenciosos do que o próprio suporte da softwell...

    O que é alegado pelo suporte é justamente a incompatibilidade entre versões... e na documentação (até mesmo no link qie voce postou) encontra versões diferentes da descrita pelo tutorial de instalação....

    e a minha revolta é: se eu seguir os passo a passo não funciona... e é justamente isso que o "meu cliente" bateu forte, se não existe nenhum padrão do fabricante, como ele terá garantia...

    eu desenvolvi na versão 2.6 do maker, e o webrun 2.6, nada em versão 2.7...

    O profissional "do meu cliente" escreveu um scripty dentro do catalina, além de declarar e exportar as variáveis utilizadas.... só assim o aplicativo funcionou mas os relat'roios não

    o suporte pediu para instalar o wine 1.2.2... e configurar com os pacotes winetricks..... com o reportcontroler 2.6.1.60, o interessante que esta versão do reportcontrole NÃO funciona com o wine 1.2.2 so com a versão 1.4..... gerando uma desconfiança do cliente, pois nem mesmo os caras do suporte sabem o que estão falando.... e ter que baixar pacotes do linux de versões muitos antigas é complicado, e eles alegam que é problema de versão..rs.rs.rs.rs. brincadeira...

    pense na seguinte situação:
    tenho uma máquina formatada e instalado somente a distribuição do linux Ubuntu 12.4.Quais os próximos passos ! qual a versão exata dos pacotes a serem instalados. NINGUEM consegue ao menos explicar ou documentar isso... quando escrevem algo deixa para o usuário decidir a versão dos pacotes, ou seja, sempre uma brecha para colocar falha na instalação.
    e outro detalhe quando tem que instalar, acredito que seja baixar o pacote e instalar, quando se diz CONFIGURAR, significa que o pacote já se encontra instalado e algo deve ser definido, modificado, incluído ou qualquer outra coisa.. e não se acha isso em local nenhum.

    O Cliente, me disponibilizou um cara muito bom em linux... só que o gerente autoriza dar continuidade na instalação do produto com um tutorial que contenha passo a passo do que fazer, a qual ele vai seguir a risca, sem inventar nada ou modificar nada por conta própria (tipo o que foi feito de escrever dentro do catalina)! Além disso ele quer que eu leve todos os pacotes a serem instalados, ele não autoriza mais baixar nada da net. eu que tenho que ser responsável pelos pacotes.

    Detalhe... O cliente tem razão.... se o aplicativo é meu, eu que tenho que informar ou instalar os componentes utilizados pelo Maker.

    mesmo com a situação atual, o sistema rodando, mas com os relatórios com problema..... não foi autorizado a entrada em produção, por estar vulnerável... com outras palavras.. se eu não apresentar um tutorial coerente e que funcione, o cliente não acreditará que o sistema funcionará e que vai gerar outros problemas, e que ele não vai gastar R$ com isso...

Log in to reply