Após Publicação não grava.



  • Efetuei a publicação de uma aplicação desenvolvida no Maker para um outro servidor dentro da minha empresa mesmo.

    Criei o banco de dados, efetuei o SCRIPT do banco de dados para as tabelas basicas do Maker.

    Efetuei o Script de criação das tabelas utilizadas pelo sistema.

    Gerei o .WAR da aplicação e coloquei dentro do servidor 2003 que tambem ja tem o Webrun instalado.

    A aplicação abre sem problemas, mas em todos os cadastros do sistema quando crico para salvar ele não salva os dados nas tabelas.

    O que posse ter feito de Errado ?


  • As PK... verifique as pk das tabelas em que está tentando gravar...
    verifique também se no seu banco de desenvolvimento que vc gerou o .war se nas
    definições do formulário se em Chaves e Atualização os Campos Chave estão marcados..


  • Olhe o log do tomcat.

    Pode ser que esteja ocorrendo algum erro na tabela fr_log_event (chave duplicada, por exemplo). Se for isso, vc pode apagar os registros desta tabela (perderá o histórico de logs)...


  • Na verdade eu resolvi o problema, criando um novo Banco de Dados através de um Backup do banco de dados que utilizei para o desenvolvimento e apagando as tabelas que não iria utilizar, deixando apenas as tabelas que existem no Script de criação do BD para publicação.

    Funcionou, mas gostaria de entender qual o processo correto para publicação, fazer o que fiz ou seja sempre que for publicar criar um backup do BD de desenvolvimento e apagar as tabelas não utilizadas ou criar um banco de dados novo e rodar o Script de criação das tabelas para publicação ?

    e quando eu efetuar alguma mudança no sistema tipo criar um novo formulario e tabela nova devo apenas rodar o Script para criação dessa nova tabela no BD de publicação ou preciso atualizar mais alguma coisa ?

Log in to reply