Problema com Lista Dinamica e Postgres9 UTF8



  • Estou com problema com esse componente quando no webrun vou pesquisar um valor, retorna a mensagem: "Conversão de Codificação de UTF8 para ASCII não é suportada".
    Já li a respeito e tentei fazer como no site: http://wiki.softwell.com.br/PostgreSQL_8 criei a variavel ServerCharset=UTF8/LATIN1 setando o valor mais naum adiantou nada ... se possível me ajudem no uso do maker com charset UTF8!

    A imagem do erro esta anexa a mensagem!!!


  • Já viu o procedimento do link http://suporte.softwell.com.br/maker/manual2_7/pt/dicas_e_truques/diversos/charset.htm ?

    Sugiro que utilize o Webrun UTF-8. Outra coisa, caso o erro persista, adicione os detalhes do erro.


  • Eu fiz exatamente o mesmo procedimento, mas agora o que acontece é que não consigo conectar o webrun no banco !!!!! A imagem esta anexa!!!! O campo BANCO abaixo do campo SERVIDOR nao permite preenchimento do nome do banco, fazendo com que eu não consigo abrir a aplicação.
    [409_screenshot__12h_50m_14s_.jpg](/assets/uploads/files/409_screenshot__12h_50m_14s_.jpg)


  • Qual erro apresentado? Consegue acessar pelo Maker?


  • Sim Pelo Ambiente de Desenvolvimento consigo somente no webrun que esta dando erro para acessar o banco, li a respeito e vi que tem o webrun utf8 e baixei mas so vem um arquivo webrun.war naum estou sabendo como instalar e seria uma tentativa para solucionar o problema trocar para essa webrun utf8?


  • Sim, seria.


  • Naum surtiu efeito , o que acho estranho que nem as aplicaçoes de exemplo do maker conseguem configuracao de banco. Vou tentar reintalar o maker pra ver o que acontece e te mantenho informado se deu certo...


  • Esgotei meus testes, naum deu certo criando um projeto novo e colocando o .wre no webrun utf8 fica do mesmo jeito naum consigo acessar o banco na tela de configurações igual ao anexo que mandei .... Voce poderia me dar uma dica para conseguir usar utf8 com maker......q naum dê problema nas listas dinamicas....?


  • Como vc faz para usar o maker 2.7 com postgres em utf8, sem dar problema com lista dinamica ao pesquisar? Voce usa ou conhece quem usa? Pois estamos em fase de pesquisa do Projeto, mas estamos há mais de tres semanas barrado com esse problema, pois não queríamos mais usar com Latin1, que é o que usamos em projetos antigos, mas os novos estamos querendo usar em utf8 e migrar os antigos para tal...mas naum estou conseguindo pois da erro no webrun nao possibilitando acesso ao banco e parece ser problema no webrun mesmo pois nao acessa o banco nem dos projetos de exemplo do maker... ja tentamos o webrun utf8 mas acontece o mesmo... o que devo fazer amigao?

Log in to reply