AcaoIniciarComponente



  • Ajuda Urgente!!!!!!

    Uma aplicação que foi desenvolvida no Maker 3.9 funcionava bem já publicada. Fiz algumas alterações e nela incluir o componente tabela e a mesma funciona no webrun e quando publicada fica com problema em uma regra, não encontra uma determinada regra.

    Procurei a regra em outros projetos e não encontrei. Não sei se o problema tem haver com a utilização do componente tabela, mas foi o único ajuste feito na aplicação.

    A aplicação funciona no Webrun e não funciona publicada.

    Exceção Gerada

    m.systems.system_spf.rules.AcaoIniciarComponente at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1680) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Unknown Source) at wfr.util.WebrunClassLoader.forName(WebrunClassLoader.java:54) at wfr.rules.WFRRuleManager.getRuleInstance(WFRRuleManager.java:482) at wfr.rules.WFRRuleManager.getRuleClass(WFRRuleManager.java:125) at wfr.web.actions.ExecuteRuleAction.execute(ExecuteRuleAction.java:164) at wfr.web.Action.doAction(Action.java:126) at wfr.web.Controller.process(Controller.java:130) at wfr.web.Controller.doPost(Controller.java:70) at javax.servlet.http.HttpServlet.service(HttpServlet.java:643) at javax.servlet.http.HttpServlet.service(HttpServlet.java:723) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at wfr.web.ContextFilter.doFilter(ContextFilter.java:87) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:879) at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:617) at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1778) at java.lang.Thread.run(Unknown Source)
    Exceção Gerada

    Desde já agradeço.

    Juliano Roque


  • Da uma limpada no cache do tomcat e reinicia o mesmo..
    Se tava funcionando, vai voltar certinho.


  • Anderson, bom dia.

    O problema não era o cache, o procedimento mencionado por você eu fiz logo que o problema ocorreu.
    Na verdade o problema era que a regra não foi no pacote WAR da aplicação. Peguei a regra em uma salva da publicação anterior e copiei para a nova publicação, Com isso o problema deixou de ocorrer.

    Obrigado pela ajuda.

Log in to reply