Memória JVM



  • Senhores, boa tarde.

    Publiquei uma pequena aplicação onde não existe muito processamento e após a publicação verifiquei que a mesma está com um comportamento bem diferente do ambiente Webrun. A aplicação está instável devido a um alto consumo de memória. Não executo nenhum processo na aplicação e o estouro de memória é apenas com a entrada na mesma. Alguém saberia informar como posso customizar o utilização da memória? Este comportamento só é verificado na aplicação publicada.

    Data Usuário Memória Utilizada
    02/06/2016 07:55 homewine 522556Kb
    02/06/2016 08:15 homewine 540836Kb
    02/06/2016 08:35 homewine 556524Kb
    02/06/2016 08:45 homewine 550424Kb
    02/06/2016 08:55 homewine 528880Kb
    02/06/2016 09:20 homewine 583320Kb
    02/06/2016 10:15 homewine 547744Kb
    02/06/2016 10:30 homewine 526364Kb
    02/06/2016 10:50 homewine 542988Kb
    02/06/2016 11:20 homewine 571996Kb
    02/06/2016 12:50 homewine 543456Kb

    Tenho o limite de 640Mb .

    Att, Juliano Roque


  • [quote="juliano"]Senhores, boa tarde.

    Publiquei uma pequena aplicação onde não existe muito processamento e após a publicação verifiquei que a mesma está com um comportamento bem diferente do ambiente Webrun. A aplicação está instável devido a um alto consumo de memória. Não executo nenhum processo na aplicação e o estouro de memória é apenas com a entrada na mesma. Alguém saberia informar como posso customizar o utilização da memória? Este comportamento só é verificado na aplicação publicada.

    Data Usuário Memória Utilizada
    02/06/2016 07:55 homewine 522556Kb
    02/06/2016 08:15 homewine 540836Kb
    02/06/2016 08:35 homewine 556524Kb
    02/06/2016 08:45 homewine 550424Kb
    02/06/2016 08:55 homewine 528880Kb
    02/06/2016 09:20 homewine 583320Kb
    02/06/2016 10:15 homewine 547744Kb
    02/06/2016 10:30 homewine 526364Kb
    02/06/2016 10:50 homewine 542988Kb
    02/06/2016 11:20 homewine 571996Kb
    02/06/2016 12:50 homewine 543456Kb

    Tenho o limite de 640Mb .

    Att, Juliano Roque[/quote] Tem alguma tarefa agendada ou algo do tipo? Disponibiliza Webservice?


  • Ronélio, bom dia.

    Esse é o mistério, não tenho nenhuma rotina agendada e também não tenho nenhum webservice. É um sistema sem processamentos com apenas cadastro e consulta.

    Att, Juliano Roque


  • [quote="juliano"]Ronélio, bom dia.

    Esse é o mistério, não tenho nenhuma rotina agendada e também não tenho nenhum webservice. É um sistema sem processamentos com apenas cadastro e consulta.

    Att, Juliano Roque[/quote]
    Certo. Utiliza qual versão do Maker/Webrun?

    Já experimentou remover os arquivos da pasta autodeploy deixando apenas os componentes utilizados?


  • Ronélio, boa tarde.

    nunca fiz isso. tem alguma documentação para falar o que posso remover ou não?

    Utilizo neste projeto a versão Maker 3.8.1.20

Log in to reply