Erro ao Gerar Relatórios - versão 3,7



  • Bom dia, estou com problemas. Migrei um sistema feito na versão 2.7 para a versão 3.7 do Maker. Até aí tudo normal. Foi solicitado um novo relatório neste sistema. Fiz normalmente. Gerei o arquivo .WAR, publiquei mas o relatório não abre. Dá a seguinte mensagem: "Erro ao Gerar Relatório - Property save device settings does not exist". Fiz outro teste. Alterei um relatório existente e este passou a dar a mesma mensagem e não abre mais. Fiz o autotest. Substuti a pasta Reports do meu sistema pela pasta Reports do ambiente de desenvolvimento. E continua com problema. Preciso de ajuda pois não consigo voltar para a versão 2.7 e o sistema está parado. Obrigado desde já.


  • Provavelmente sua versão de desenvolvimento ou .WAR esta desatualizada.

    No autotest, localize a pasta com HASH e remova todo o conteúdo dela. Reinicie o Tomcat e testa novamente.


  • Boa tarde. Este autotest tem que ser feito no servidor ou na máquina de desenvolvimento? Esta pasta com hash é a pasta que aparece no autotest? Como localizo ela no autotest? Não entendi o que é esta pasta. Obrigado


  • O autotest é uma opção no Webrun para verificar o caminho dos arquivos

    Veja este link
    http://suporte.softwell.com.br/maker/manual_3/pt/estrutura_maker_e_webrun/estrutura_de_pastas_do_webrun.htm

    Deverá ser feito na máquina que apresenta o problema.


  • Bom Dia. A sua orientação deu certo. Muito obrigado pela sua atenção.


  • Ok!

Log in to reply