Relatório não é gerado no Linux usando Wine



  • Olá,

    Estou responsável por fazer o deploy de uma aplicação feita em Maker em um servidor Linux.

    Li todos os tutoriais disponíveis na documentação do Maker e li também o link da Wiki de como instalar no sistema CentOS:
    [url]http://suporte.softwell.com.br/maker/manual2_7/pt/recursos_avancados/instalacao_webrun_distribuicao_linux_ubuntu_ou_fedora.htm[/url]
    [url]http://suporte.softwell.com.br/maker/manual2_7/pt/webrun_2/instalando_o_webrun_no_fedora_Core9_.htm[/url]
    [url]http://suporte.softwell.com.br/maker/manual2_7/pt/dicas_e_truques/banco_de_dados/usando_mysql_no_linux.htm[/url]
    [url]http://suporte.softwell.com.br/maker/manual2_7/pt/dicas_e_truques/webrun/procedimentos_para_instalacao_de_um_ambiente_dedicado_para_o_webrun_no_linux.htm[/url]
    [url]http://wiki.softwell.com.br/WebrunCentOS5[/url]

    Apesar das inconsistências entre os cinco que deveriam conter exatamente a mesma coisa, fui capaz de rodar o sistema em um Servidor Tomcat 6 usando um pacote WAR da aplicação que me foi passado, porém a geração de relatórios não funcionava e o ReportEngine.exe nem era executado.
    Após muito batalhar, fui capaz também de configurar o Wine e o sistema passou a chamar o ReportEngine.exe, porém independente da configuração do Wine ou do sistema o resultado é sempre o mesmo:
    [code]Access violation at address 00401F2F in module 'ReportEngine.exe'. Leitura of address 00000000[/code] O sistema ficá eternamente em uma mensagem de espera e caso eu a feche e tente novamente então a mensagem acima é exibida para o usuário.
    Se abro um monitor de processos, vejo três processos do ReportEngine.exe e um do ReportController.exe que não estão utilizando nada de CPU, estão simplesmente lá esperando que alguém os mate manualmente.

    Por favor, alguém poderia me dar direções do que pode ser o problema?
    Já configurei o Wine com tudo o que é requisitado nos tutorias citados e a aplicação está rodando perfeitamente com exceção dos relatórios.

    Desde já agradeço qualquer ajuda.


  • Segue LINK com a VM LinuxCentos5 funcionando. Olha o history do root para ver como foi feito.
    http://download.softwell.com.br/testes/CentOS.Grafico.x86.Webrun.ReportController.rar

    Usuário: root
    Senha: softwell

Log in to reply